[SOLVED] “Error: Dependency is not satisfiable: libnautilus-extension1 (>= 1:2.22.2)” while installing dropbox

I downloaded nautilux-dropbox Ubuntu deb package from Dropbox Linux Download Page. When I tried to install it via gdebi deb installer in Debian, I got the following error:

Error: Dependency is not satisfiable: libnautilus-extension1 (>= 1:2.22.2)

If you add repos and try to install it from there via Synaptic, you will get the error:

nautilus-dropbox:
Depends: libnautilus-extension1 (>=1:2.22.2) but 2.30.1-2 is to be installed

If you install it with dpkg -i, you will get the following error:

Selecting previously deselected package nautilus-dropbox.
(Reading database … 229404 files and directories currently installed.)
Unpacking nautilus-dropbox (from nautilus-dropbox_0.6.7_i386.deb) …
dpkg: dependency problems prevent configuration of nautilus-dropbox:
nautilus-dropbox depends on libnautilus-extension1 (>= 1:2.22.2); however:
Version of libnautilus-extension1 on system is 2.30.1-2.
dpkg: error processing nautilus-dropbox (–install):
dependency problems – leaving unconfigured
Processing triggers for gnome-menus …
Processing triggers for desktop-file-utils …
Processing triggers for hicolor-icon-theme …
Processing triggers for man-db …
Errors were encountered while processing:
nautilus-dropbox

Using the dpkg method will result in broken packages.

I had downloaded the version 0.6.7 32 bit (i386) i.e. nautilus-dropbox_0.6.7_i386.deb and was unable to install it cleanly. However, when I ran it by force installing, it ran without problems but the package was broken. So, the problem was not with the unmet dependencies but the deb file wrongly specifying dependencies.

So, I decided to fix the deb file. I unpacked the deb:

mkdir -p extract/DEBIAN
dpkg-deb -x nautilus-dropbox_0.6.7_i386.deb extract/
dpkg-deb -e nautilus-dropbox_0.6.7_i386.deb extract/DEBIAN/

Then edited the extract/DEBIAN/control file with gedit. You can use any other text editor of your choice.
The “Depends:” line looks like the following:

Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.12.0), libnautilus-extension1 (>= 1:2.22.2), libpango1.0-0 (>= 1.20.1), python (>= 2.5), python-gtk2 (>= 2.12)

Notice the entry “libnautilus-extension1 (>= 1:2.22.2)”. In my installation, the version of libnautilus-extension1 is 2.30.1 and not 1:2.30.1 (which is the version format for libnautilus-extension1 in Ubuntu). So, I edited the version number to 2.22.2 instead of 1:2.22.2. So, the new depends line looks like the following:

Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.12.0), libnautilus-extension1 (>= 2.22.2), libpango1.0-0 (>= 1.20.1), python (>= 2.5), python-gtk2 (>= 2.12)

After the change, create a directory called build and run the dpkg-deb command with -b switch to build the new deb file:

mkdir build
dpkg-deb -b extract/ build/

You will find a deb file in build/ directory which should install without dependency problems.

After installing, install the service by running the following as root and you are all done:

dropbox start -i

Hope this helps.

  • epsilonhalbe

    super this was a real big help – merci/thanks/danke 😉
    yours ε/2

  • marconipoveda

    I really works, thanks!

  • RuiPedro

    Thank you , worked like a charm !!

  • I think it make sense to change version field too, because of conflict with original (the same number) version from deb http://linux.dropbox.com/ubuntu maverick main. Something like ‘0.6.7-my1’

  • Halkovaja

    Soon there are no more reasons for me to drop OSX for Debian. Thank you!

  • Flamelcanto

    Genial, muy buena explicación

  • Avanco_89

    Thanks… Great job

  • Pingback: Running Dropbox Under Debian Linux « zebpedersen.co.uk()

  • Juan AR

    Thanks a lot! This help me in debian wheezy too. 😉

  • Thanks for this! It helped me install ZumoDrive on Linux Mint Debian Edition (LMDE), too.

  • Buddhi1980

    It works also when install it from the surce files. After compilation it works perfectly. From .deb files I had the same problem (Debian 6.0.1, KDE 4.4)

  • Sadsdffsdf

    thank you!!

  •  Thanks Man .. It works to install the zumodrive in debian… thanks

  •  Thanks Man .. It works to install the zumodrive in debian… thanks

  •  Thanks! worked great 😀 I couldn’t install from source, your guide solved my problem 🙂 btw, i translated it into Spanish http://bit.ly/jS0K4d 🙂

  • H1n1

    Thank you!

  • i translated in italian and adapted this article on my blog. thank you very much!

    the link of the italian translation in this, for who need:
    http://tinyurl.com/69z7ukk

    • Great, please link back to this article.

  • Richard Reijmers

    Great stuff, helped a lot!! Thanks!!

  • Gustavo de Freitas Caetano

    Thank you!
    This post helped me a lot!

  • Pingback: Debian Installation | Thoughts of a sleepy brain()

  • rogerio rag

    I my Debian the
    libnautilus-extension1 is libnautilus-extension1a, I edited it, and works!

  • kendasuka

    Hello there!

    you have a good article with useful information, I’m really good reviews about trying your contribution, a great article

    friv | kizi | enemy

  • Mijail

    freinds please , help me, I have this all the time, every update I run
    W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-backports/multiverse/binary-i386/Packages 404 Not Found [IP: 91.189.91.13 80]

    I have the main server and UNited State Server, but whatever I use neither of them work…

    • You’re using a Quantal (12.10) repo. It has already reached end-of-life and hence the servers no longer host Quantal packages. Install a later version of Ubuntu, preferably LTS release which will be supported for a long time. Ubuntu 12.04 LTS will be supported till April 2017 and Ubuntu 14.04 will be supported till April 2019.

  • Pingback: Problemas para instalar Dropbox en Debian | Usemos Linux()