[SOLVED] No package ‘gtk+-3.0’ found

If you are trying to compile a gtk-3 application and if you don’t have development package installed here is the error you can get:

configure: error: Package requirements (gtk+-3.0 >= 3.0.0) were not met:

No package ‘gtk+-3.0’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

If you encounter this error in Fedora, you should install gtk3-devel. In terminal, type in the following:

su -c 'yum install gtk3-devel'

If you encounter this in Ubuntu, you should install libgtk-3-dev. To do so, type in the following in terminal:

sudo apt-get install libgtk-3-dev

Hope this helps.

If you enjoyed this post, make sure you subscribe to my RSS feed!
  • NattyNSVP

    hey. you better fix ur error here bro. its    

    libgtk-3-dev

  • Bill3232

    How about a step-by-step guide for installing gtk+-3.2.0 on Ubuntu ?

  • me-too

    Google saves me a lot of time. Get an error ? Use google and my problem is solved. !! Thanks !!

  • Ikem Krueger

    Thank you. That fixed it.

  • Marcel

    Thank you so much for this bit of information. I struggled with this for hours yesterday. Must not have due the proper google search.
    Worked like a charm.

  • Ano

    Thanks

  • Pierrot

    Yes, it helps ! Thk dude 🙂

  • Jan

    Thanks, it did help!

  • Marco

    Thanks it saved my life 🙂

  • diegoangel77

    many many thanks

  • netsurfer912

    It does. Thank you.

  • Louis

    Thank you!

  • Haslemere

    It gets worse. Trying to install gnumeric-1.12.20 on Debian. It wants version 3.8.7 of libgtk-3-dev but the latest version available on Debian is 3.4.2-7!!

  • Bunny =(^__^)=

    Thank you from Italy!

  • Thanks Dude! Its work!

  • Rodrigo

    tnx.. bro

  • Alexander Alemayhu

    Thanks