Tag Archives: synaptic

[HOWTO] Enable “Mark All Upgrades” in Synaptic on Linux Mint

If you are using Linux Mint Gnome or Linux Mint Debian Edition, you will notice that Ctrl+G or Mark All Upgrades is disabled. This has been done to prevent users from installing upgrades that have not been tested and verified to work by Linux Mint team. Read more in this discussion.

However, if you can take care of your packages and the problems that may arise, you may want to enable the handy feature. It can be done by following the instructions below.

Open up the terminal and remove synaptic completely:

sudo apt-get purge synaptic

Then edit out the line in the following file or remove it completely. However, if you want to be able to enable it, it is recommended to just disable the line using a # in the beginning of the line.

/etc/linuxmint/adjustments/10-mintsystem-synaptic.overwrite

To edit it, you can open in any text editor as root. For example, to edit it using gedit, you may press Alt+F2 and enter the following:

gksu gedit /etc/linuxmint/adjustments/10-mintsystem-synaptic.overwrite

Make sure the line looks like the following by adding a # in the beginning of the line:

#/usr/lib/linuxmint/mintSystem/adjustments/synaptic.glade /usr/share/synaptic/glade/window_main.glade

Save the file and exit.
Then, install synaptic again:

sudo apt-get install synaptic

While removing Synaptic, note the packages being removed and install them back:

sudo apt-get install aptoncd apturl jockey-gtk mint-meta-gnome mint-meta-main mintupdate

That’s it. Open up synaptic and you should be able to use “Mark All Upgrades” again.

If you wish to disable the mark all upgrades again, just remove synaptic and then remove the # from the same file and save it. Then, re-install synaptic again.

Hope it helps.

[HOWTO] Add Launchpad Ubuntu PPA in Debian Squeeze Testing

I have installed Debian Squeeze Testing replacing Ubuntu 10.10 Maverick Meerkat and miss some applications only available via Launchpad PPAs. Not that they can’t be compiled from their sources or installed by downloading debs, but it would be great if updates were available from update manager like in Ubuntu. So I decided to add some Ubuntu PPAs and they are working fine. So, I decided to share here with the hope that it would be helpful to my readers.

If you want to install a PPA in Squeeze Testing, make sure that the PPA has an entry for Ubuntu 10.04 Lucid Lynx. Not that it will never work with Maverick PPAs, but Lucid is a better choice as Debian Squeeze has package versions more similar to Lucid than Maverick or Natty. Thus, it is a better choice to use Lucid PPAs. Instead of using just the PPA name (for example ppa:tiheum/equinox for Equinox theme PPA) use the deb line for Lucid (eg. deb http://ppa.launchpad.net/tiheum/equinox/ubuntu lucid main ) and add it to /etc/apt/sources.list or Software Sources (or Synaptic>Settings>Repositories>Third Party Source). After adding that, copy the PPA signature (available in “Signing Key” section in PPA page), eg. 1024R/4631BBEA for Equinox Theme PPA. Just use the part after “/” (i.e. 4631BBEA for this example) and use the following command in the terminal to get GPG keys for the PPA:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4631BBEA

Note: If you are not able to sudo, you may either enable it or use su followed by commands instead.
After that, reload the package list and install the package.

This may not work for every program that there is but it works for many. Hope this helps.

Fixing Slow, Choppy and Laggy Maverick Meerkat (Ubuntu 10.10)

A lot of Ubuntu 10.10 users have been complaining about Maverick being too slow, typing becoming laggy and video performance being choppy.   Here are few things you can try to make it fast again. These have been collected from the user experience discussed in this post in Ubuntu forums.

Update your kernel to latest Mainline kernel

Ubuntu Maverick Meerkat uses version 2.6.35 of Linux Kernel. A lot of users have solved their problems by upgrading to version 2.6.36. You can do so by downloading the deb files and installing them from the Ubuntu Kernel Mainline PPA: http://kernel.ubuntu.com/~kernel-ppa/mainline/ Open the latest version that is available (rc8 is the latest in the time of writing this, however only 64bit is available, if you have 32-bit, use rc7) and download the following files:
linux-headers-VERSION_all.deb
linux-headers-VERSION-generic_VERSION_amd64.deb
linux-image-VERSION-generic_VERSION_amd64.deb

If you have 32bit, choose the ones that contain i386 instead of amd64 in the name.
Install them one by one in the same order as listed above and reboot.

Note that if that does not help and if you want to switch back to 2.6.35 kernel again, you can always remove 2.6.36 kernel from Synaptic Package Manager (Alt+F2>gksu synaptic). Also note that you will not get updates to 2.6.36 even if newer versions are out, so you should update manually later if you find newer versions of 2.6.36 kernels.

Clean install

If upgrading the kernel doesn’t help you, you may want to clean install in case you have upgraded from previous versions. That may not help most of you, but still might. If you have installed 64-bit version, you may even want to switch to 32bit version as many users have reported to have no problems with 32bit version. If you install 32-bit version and have 4GB or more RAM, you should install linux-generic-pae kernel from Synaptic Package Manager so that your system can make use of all of your RAM. Some users have also mentioned going to LinuxMint has solved their problems. Or if all elese fails, go back to Lucid (10.04) and wait for Natty Narwhal (11.04) to be released.

Hope this helps.

[SOLVED] “Package dependencies cannot be resolved” while installing qgis-plugin-grass

I was trying to install GRASS Plugin for Quantum GIS (qgis-plugin-grass) in my Ubuntu 10.10 Maverick Meerkat while I got the following error in Ubuntu Software Center:

Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

I then launched Synaptic Package Manager (from System>Administration menu) and tried to install qgis-plugin grass and got the following error message:

qgis-plugin-grass:
Depends: libgdal1-1.6.0-grass but it is not going to be installed

I then tried to install libgdal1-1.6.0-grass which gave me the following error:

libgdal1-1.6.0-grass:
Depends: grass640-6 but it is not installable

I looked for grass640-6 package but it was not available. However, a package named grass was available which was at version number 6.0.4-rc6 was available. I decided to make a new dummy transitional package (which the developers should have done). To do so, I just created a directory grass640 with another directory DEBIAN and created a file control inside it:

mkdir -p grass640/DEBIAN
touch grass640/DEBIAN/control

Then, I opened up control file that I just created in gedit:

gedit grass640/DEBIAN/control

and wrote the following content and saved it:

Package: grass640-6
Source: grass
Version: 0.6.4.0-6
Architecture: all
Maintainer: khattam@khattam.info
Installed-Size: 0
Depends: grass
Priority: extra
Homepage: http://www.khattam.info
Description: transitional dummy package for grass
 transitional dummy package to pull in grass

Then, I built the debain file:

dpkg-deb -b grass640/ ./

As a result, I got a file named grass640-6_0.6.4.0-6_all.deb in my current directory. If you don’t want to create it, you can use mine from here. Then I just installed it by double clicking on it. After that, I could install qgis-plugin-grass without problems.

Hope this helps.

[HOWTO] Recover an application that was removed due to update in Ubuntu and other Debian based systems

Sometimes when you are using PPA repositories or mixing multiple repositories or using a Development version, you encounter a problem and some of your applications might be removed. I want to illustrate the problem with my current Ubuntu 10.10 Maverick Meerkat Alpha installation, which I use as the only OS in my computer. This is not recommended but since I have always managed to solve issues that come up due to development versions, I have mostly used development versions because I get to see the upcoming changes and report problems if anything that bothers me.
With the latest repositories list update, I got into a problem with Filezilla, because I have been using Lucid getdeb repo with my system and Filezilla is in their repo as well as the official repo. When I marked for the latest updates in Synaptic Package Manager, I could see that filezilla, amongst others, was in the package to be removed which was because the package filezilla-common was to be upgraded and the filezilla that was installed, and had no update, had dependency issues. I upgraded the package filezilla-common anyways and lost filezilla. Ideally, since I am using a development version, I should have marked all the changes, and then reviewed the list of programs that are to be removed and unmark them or mark them for reinstallation which automatically unmarks the conflicting updates. Since packages like gdm, gnome-panel and some others which are required for the system to boot properly into the desktop were also marked for removal, I marked them for re-installation or unmarked them so that they remained in the system. But for experimenting, I did not mark it and it got removed. Now, when I try to install the package, I get the error:

filezilla:
Depends: filezilla-common (=3.3.2.1-1ubuntu1) but 3.3.3-1ubuntu1 is to be installed

and it cannot be marked for installation.
Since I need filezilla, I need to get it back installed. For this, the easiest way is to remove the alternate repository and reload the software list. If that does not help, you could just wait for the next repository update and reload it and then install it.
If you can’t wait or if that does not solve the problem, then you can follow the method I explained with 0ad here in my older blog post. I can also find the compatible deb file (download it from some other location and check for compatibility) and install it with gdebi (double click).
If you can’t find it, just find the latest version (which may be found in the directory /var/cache/apt/archives or can be downloaded from http://packages.ubuntu.com) and then install with dpkg i.e.

sudo dpkg -i filezilla_3.3.2.1-1ubuntu1_amd64.deb

This will, however, leave broken packages and synaptic will not let you do any other installation/update without resolving it. But most of the time, you can run the particular program without problems. The next update might fix the problem and you can just reinstall the broken package. But in case if it does not or if you don’t want to wait, you can downgrade to the older version of the conflicting package that you upgraded which caused your program to be removed. You can find the deb online or in /var/cache/apt/archives and install it using dpkg. In my case, it is the older version of filezilla-common that I need. So, all I do is run the following command to install the older version which will replace the newer version:

sudo dpkg -i /var/cache/apt/archives/filezilla-common_3.3.3-1~getdeb2_all.deb

and then to reconfigure the package filezilla, I also installed the older version of filezilla:

sudo dpkg -i /var/cache/apt/archives/filezilla_3.3.3-1~getdeb2_amd64.deb

Hope this helps resolving and recovering your lost programs.

[SOLVED] ERROR: Depends: binutils (<2.20.2) but 2.20.51.20100710-1ubuntu2 is to be installed while installing 0ad from getdeb in Maverick

I am using Ubuntu 10.10 Maverick Meerkat and have getdeb (playdeb) repository for Lucid Lynx. Lucid repo can be added to Maverick and many applications can be installed without problems. However, I got this error while trying to install a game called 0ad.

0ad:
Depends: binutils (<2.20.2) but 2.20.51.20100710-1ubuntu2 is to be installed

I could downgrade my binutils to an appropriate version by downloading deb from somewhere else and that would be the ideal thing to do if it did not break any packages, but I decided not to as it could break other packages and decided to try out something that is never recommended and should not be done if you don’t know what you are doing. You should know that this could also lead to broken packages but fortunately this only breaks a game (that is what I am going to install) at worst and not some system program. I just changed the dependency to the version that I had by editing the package description. To do so, I needed to open the file /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_lucid-getdeb_games_binary-amd64_Packages as root by running

gksu gedit /var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_lucid-getdeb_games_binary-amd64_Packages

If you are using 32-bit version of Ubuntu, you should probably try something else.

The package description for 0ad looks like the following:

Package: 0ad
Version: 0.0.0+r07539~pre-alpha-1~getdeb1
Architecture: amd64
Maintainer: Christoph Korn
Installed-Size: 10412
Depends: binutils (>= 2.20.1-3ubuntu2), binutils (<< 2.20.52), libboost-filesystem1.40.0 (>= 1.40.0-1), libboost-signals1.40.0 (>= 1.40.0-1), libboost-system1.40.0 (>= 1.40.0-1), libc6 (>= 2.11), libdevil1c2, libenet0debian1, libgamin0 | libfam0, libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libjpeg62, libopenal1, libpng12-0 (>= 1.2.13-4), libsdl1.2debian (>= 1.2.10-1), libstdc++6 (>= 4.4.0), libvorbisfile3 (>= 1.1.2), libwxbase2.8-0 (>= 2.8.10.1), libwxgtk2.8-0 (>= 2.8.10.1), libx11-6 (>= 0), libxml2 (>= 2.7.4), zlib1g (>= 1:1.2.0), 0ad-data
Homepage: http://wildfiregames.com/0ad/
Priority: normal
Section: games
Filename: pool/games/0/0ad/0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb
Size: 3835504
SHA256: d21eea643c4fc6cef6564f1eacbc1bf3a2ef7ca813cbb9cc69912e45ae7708a4
SHA1: 504cdbc3fb2acc6ab4a57ab3bddb652a05910f3d
MD5sum: 8dfced6b1af656f5ff820861e621f393
Description: A war/economy strategy game
A historically based Real Time Strategy game focusing
on the years 500 B.C. to 500 A.D.
.
In short, it is a war/economy strategy game allowing
you to recreate or rewrite the ancient history of western
civilisations.

I changed the line in the “Depends” from binutils (<< 2.20.2) to binutils (<< 2.20.52) and restarted synaptic package manager. Then I could download the game without problems. But it shows dependency errors and the game can’t be configured. So, I removed it from Synaptic. Then what I do next is copy the 0ad deb file to my desktop; mine is called 0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb and it is in /var/cache/apt/archives/. So, I fire up the terminal and do the following:

sudo cp /var/cache/apt/archives/0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb /home/[USERNAME]/Desktop/

where [USERNAME] is my username. Now the game is copied onto my desktop. Now I changed the owner to myself, so that I can read it:

sudo chown [USERNAME] /home/[USERNAME]/Desktop/0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb

Then, I needed to edit the control file and repack the deb. To do so, I just extracted it:

cd ~/Desktop
mkdir -p extract/DEBIAN
dpkg-deb -x 0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb extract/
dpkg-deb -e 0ad_0.0.0+r07539~pre-alpha-1~getdeb1_amd64.deb extract/DEBIAN/

Then, I edited the control file:

cd extract/DEBIAN
nano control

and changed the file to say binutils (<< 2.20.52) instead of binutils (<< 2.20.2). Just Ctrl+O followed by ENTER to write the changes and Ctrx+X to exit nano. Then, I just went back to the Desktop folder.

cd ../../

Then I repackaged the deb file:

mkdir build
 dpkg-deb -b extract/ build/

Then, I could find the new deb inside the build folder in the Desktop which I can install without problems. After it is installed, I tried to launch it from the terminal (0ad) but I got an error saying:

./pyrogenesis: error while loading shared libraries: libbfd-2.20.1-system.20100303.so: cannot open shared object file: No such file or directory

So, it really needs the binutils version it says it does. Anyways, just creating a symbolic link named libbfd-2.20.1-system.20100303.so in /usr/lib to the version that I have i.e. libbfd-2.20.1-system.20100303.so did it for me. To do so, in terminal I typed the following:

sudo ln -s /usr/lib/libbfd-2.20.51-system.20100710.so /usr/lib/libbfd-2.20.1-system.20100303.so

Hope this helps.

[SOLVED] “BADSIG 40976EAF437D05B5” when reloading package lists in Synaptic/apt/update-manager in Ubuntu 10.04 Lucid Lynx

[ad#ad-1]I am using Ubuntu 10.04 Lucid Lynx Beta 1 and got the following set of warnings while updating my package lists

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.ubuntu.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key 

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/lucid/Release  

W: Some index files failed to download, they have been ignored, or old ones used instead.

This was preventing the package list updates and hence preventing package updates. I don’t know what caused this or when exactly I started to get these, but I guess it was after I changed my packages server from np.archive.ubuntu.com to archive.ubuntu.com.

Anyways, I managed to fix it by (re)moving all the old package lists and updating again. This can be summed up in the following three lines of terminal commands:

sudo mv /var/lib/apt/lists /var/lib/apt/lists.old
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get update

This did it for me. Hope it does it for you too.

[SOLVED] Gtk-Message: Failed to load module “rgba”: librgba.so: cannot open shared object file: No such file or directory

[ad#ad-1]I had enabled the ppa

ppa:erik-b-andersen/rgba-gtk

and upgraded and installed nautilus, murrine-themes , gtk2-module-rgba and gtk2-engines-murrine to enable rgba transparency in my Ubuntu 10.04 Lucid Lynx Alpha. That looks really cool. It was supposed to be coming with Lucid, but was dropped due to bugs. The programs started crashing for me too. I was done with adding exceptions to /etc/profile.d/gtkrgba.sh because almost every new program crashed. So I decided to remove the rgba module altogether. Just removing the repository does not help. So, here are the removal instructions. Continue reading [SOLVED] Gtk-Message: Failed to load module “rgba”: librgba.so: cannot open shared object file: No such file or directory

[SOLVED] “subprocess pre-removal script returned error exit status 2” error

[ad#ad-1] Recently, I encountered a package management related error in Ubuntu Jaunty Jackalope 64bit.

The package was python-beagle and the error was: “E: python-beagle: subprocess pre-removal script returned error exit status 2” and details showed:

dpkg (subprocess): unable to execute pre-removal script: Exec format error
dpkg: error processing python-beagle (–remove):
subprocess pre-removal script returned error exit status 2
dpkg (subprocess): unable to execute post-installation script: Exec format error
dpkg: error while cleaning up:
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
python-beagle
E: Sub-process /usr/bin/dpkg returned an error code (1)

I managed to fix it. Read on for how I did it. Continue reading [SOLVED] “subprocess pre-removal script returned error exit status 2” error