Tag Archives: ubuntu 9.04

[SOLVED] “subprocess pre-removal script returned error exit status 2” error

[ad#ad-1] Recently, I encountered a package management related error in Ubuntu Jaunty Jackalope 64bit.

The package was python-beagle and the error was: “E: python-beagle: subprocess pre-removal script returned error exit status 2” and details showed:

dpkg (subprocess): unable to execute pre-removal script: Exec format error
dpkg: error processing python-beagle (–remove):
subprocess pre-removal script returned error exit status 2
dpkg (subprocess): unable to execute post-installation script: Exec format error
dpkg: error while cleaning up:
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
python-beagle
E: Sub-process /usr/bin/dpkg returned an error code (1)

I managed to fix it. Read on for how I did it. Continue reading [SOLVED] “subprocess pre-removal script returned error exit status 2” error

A better Torrent Client For Ubuntu 9.04 (Jaunty Jackalope)

[ad#ad-1]Transmission is the default torrent client with Ubuntu. However, I love ktorrent because of the various features it provides. As I use ubuntu and KDE based softwares require kdelibs to be installed, I usually go for alternatives and I found deluge to be a great alternative for ktorrent. It provides similar features as ktorrent.

It can be installed directly via Synaptic but for the latest version, just type in the following in the terminal window. The following instructions apply to Ubuntu 9.04 (Jaunty Jackalope).
Continue reading A better Torrent Client For Ubuntu 9.04 (Jaunty Jackalope)

[HOWTO]Install Firefox 3.5 in Jaunty Jackalope and Make Add-Ons Compatible

[ad#ad-1]Firefox 3.5 is out for other OSes however the final version is not available for Linux. This is how you install it on your Jaunty Jackalope installation. We will use the terminal for this. It is just a copy and paste from here to your terminal so it should be fine. Continue reading [HOWTO]Install Firefox 3.5 in Jaunty Jackalope and Make Add-Ons Compatible